PHP学习_PHP技术_PHP网站建设_PHP程序员专注于PHP技术研究及学习

Adophper » 编程开发 » WordPress后台为什么更新插件主题时提示输入FTP信息的解决方法

WordPress后台为什么更新插件主题时提示输入FTP信息的解决方法

自从去年将adophper博客从国外搬回国内的阿里云主机上期间发生了很多事! 阿里云服务器我选用的是centos6.2 64位操作系统,对于linux系统压力很大。 今天突然想改改主题,可是提示输入FTP用户信息。 想想阿里云主机上我没有安装FTP服务啊!于是找了一下关于WordPress安装插件主题时提示需要输入FTP信息问题解决方法 使用Linux主机的站长在WordPress后台安装插件、主题时,有的会被提示需要输入FTP信息。即时输入了FTP信息也不一定100%可以连接服务器的,比如byethost。 这应该是空间服务器的权限问题,你可以联系空间提供商解决。但大多数空间商是不会理你这个请求的。悠悠创想介绍通过修改wp-config.php实现FTP权限的方法。 在wp-config.php中找到如下代码: require_once(ABSPATH . 'wp-settings.php'); 在后面添加下面的代码: if(is_admin()) { add_filter('filesystem_method', create_function('$a','return "direct";' )); define('FS_CHMOD_DIR', 0751); } 现在尝试一下在线安装插件或主题,怎么样,不用再输入FTP信息了吧。

本站使用ThinkPHP框架开发读图网主题,目前托管在阿里云,图片由读图网提供. 蜀ICP备12031064号

Copyright © 2011-2018adophper.com All Rights Reserved.