PHP学习_PHP技术_PHP网站建设_PHP程序员专注于PHP技术研究及学习

Adophper » 服务器 » ruby链接mysql错误: Incorrect MySQL client library version! This gem was compiled for 6.0.0

ruby链接mysql错误: Incorrect MySQL client library version! This gem was compiled for 6.0.0

此文被围观1562日期: 2013-04-26 分类 : 服务器  标签:  ·····
今天在链接数据库的时候出现以下错误: [html] incorrect MySQL client library version! This gem was compiled for 6.0.0 but the client library is 5.5.20. [/html] 看一下解决办法: 从mysql官方http://dev.mysql.com/downloads/mysql下载 mysql-connector-c-noinstall-6.0.2-win32 解压到e:/。注意根据自己的实际情况下载相对应的版本,这里使用非安装版。 or Ruby 1.9.2: [html] gem install mysql --platform=ruby -- --with-mysql-dir=e:/mysql-connector-c-noinstall-6.0.2-win32 [/html] for Ruby 1.9.3: (showing mysql2 variant) [html] gem pristine mysql2 -- --with-mysql-config=e:mysql-connector-c-noinstall-6.0.2-win32 [/html] 这里我用32位的win7系统. 然后将 E:mysql-connector-c-noinstall-6.0.2-win32lib 目录下的 libmysql.lib 文件复制到 E:RailsInstallerRuby1.9.3bin 目录下。 重新执行刚才的命令即可。 文章来源:http://blog.haohtml.com/archives/13269

本站使用ThinkPHP框架开发读图网主题,目前托管在阿里云,图片由读图网提供. 蜀ICP备12031064号

Copyright © 2011-2018adophper.com All Rights Reserved.