PHP技术,PHP研究及学习,Python学习,人工智能,大数据服务

文档标签: ruby

ruby链接mysql错误: Incorrect MySQL client library version! This gem was compiled for 6.0.0.

今天在链接数据库的时候出现以下错误: [html] incorrect MySQL client library version! This gem was compiled for 6.0.0 but the client library is 5.5.20. [/html] 看一下解决办法: 从mysql官方http://dev.mysql.com/downloads/mysql下载 mysql-connector-c-noinstall-6.0.2-win32 解压到e:/。注意根据自己的实际情况下载相对应的版本,这里使用非安装版。 or Ruby 1.9.2: [html] gem install mysql --platform=ruby -- --with-mysql-dir=e:/mysql-connector-c-noinstall-6.0.2-win32 [/html] for Ruby 1.9.3: (showing mysql2 variant) [html] gem prist...
此文被围观1277次  分类: 服务器 标签:  ·····

ruby on rails环境配置.

rails的安装,rails环境配置,最近公司的事相对而言少了一些,于是想学习一下ruby 因为最近对火热的ruby感兴趣,故准备搭建ruby开发环境。感受下ruby的强大。在搭建环境的过程中,遇到了一些问题,在下文中已做记录,并奉上个人的解决方案。 在开始前啰嗦一句:本人使用环境ruby 1.9.2 ,rails 3.0.9. 1、 下载最新版ruby 网址如下:http://www.ruby-lang.org/en/downloads/ 2、 安装ruby 下载后直接为exe文件,直接下一步即可。可将[将路径添加到环境变量path中]和[关联ruby文件]两个选项选中。不解释。 3、 查看安装结果 Windows环境下,cmd中输入:ruby –v 查看ruby版本。 4、 安装rails 安装rails灰常简单,只需在命令行中执行:gem install rails --include-dependencies。 运行该命令需保证网络畅通。 安装完毕后运行:ra...
此文被围观1062次  分类: 服务器 标签:  ······

Gem::InstallError: The 'json' native gem requires installed build tools..

ruby安装错误:Gem::InstallError: The 'json' native gem requires installed build tools. 大概意思就是少了json这个工具。 1、在http://rubyinstaller.org 下载需要的ruby版本,因为是exe文件,所以,你可以直接安装。 2、下载devkit文件,然后解压安装,选择自己想要的目录。(这一步的顺序挺重要,否则第4步操作可能会出错) 3、cmd进入windows命令操作,进入devkit的文件夹下,执行下面的操作: ruby dk.rb init ruby dk.rb install 4、cmd进入windows命令操作,使用gem install rails来安装。看到“Successfully installed rails-3.1.1”,说明安装成功。 这里特别指出的就是,在第2、3步的devkit没有安装的话,可能会出现“”错误。 ERROR: Error instal...
此文被围观1605次  分类: 前端设计 标签:  ····

本站使用ThinkPHP框架开发读图网主题,目前托管在阿里云,图片由读图网提供. 蜀ICP备12031064号

Copyright © 2011-2018adophper.com All Rights Reserved.